build fail on heroku

I can't figure out why I got a build fail on heroku... I just switched a few items in my gem file, pushed it to git, and tried running a build.

-----> Ruby app detected
! different prefix: "" and "/tmp/build_77da7adde348e3aead128adf759a3e61"
/app/tmp/buildpacks/b7af5642714be4eddaa5f35e2b4c36176b839b4abcd9bfe57ee71c358d71152b4fd2cf925c5b6e6816adee359c4f0f966b663a7f8649b0729509d510091abc07/vendor/ruby/heroku-16/lib/ruby/2.5.0/pathname.rb:522:in `relative_path_from': different prefix: "" and "/tmp/build_77da7adde348e3aead128adf759a3e61" (ArgumentError)
from /tmp/d20190316-152-vbnqat/bundler-1.15.2/gems/bundler-1.15.2/lib/bundler/lockfile_parser.rb:98:in `rescue in initialize'
from /tmp/d20190316-152-vbnqat/bundler-1.15.2/gems/bundler-1.15.2/lib/bundler/lockfile_parser.rb:61:in `initialize'


Probably something going on there end? I'll try again later.

oh, it must be something to do with ruby-sass that I updated because of some vulnerabilities.

Between switching gems and a possible error or missing file in initialize has created a problem is my guess.

Cheers Dave

oh, I fixed it. I had done a merge, and my gemlock file had some weird stuff in it.

I just deleted the file, did a bundle install, pushed it back to github and was able to build it.

Sounds good Joe