auto_complete and protect_from_forgery

Hello,
There are a lot of reports about the conflict between auto_complete
plugin and the protect_from_forgery option since 2007:

http://www.ruby-forum.com/topic/128970

The solution is very easy. But I curious about why the SVN repository
haven't accept this patch and leave the problematic auto_complete
plugin there?