App migration and upgrading

Hey group,

When you take on updating an older app is it always this daunting to configure the setup? It seems like every turn there is an issue with either an outdated gem or the database. Do you have a protocol for this is it literally this trial and error.

I had this printed and taped to the side of my monitor at a previous gig
<https://boyter.org/static/books/CphhR1GW8AAeOkg.jpg>
where I was doing a fairly complex 4.0.x -> 5.x upgrade while the app
was being actively developed :slight_smile:

That said, have you read
<https://guides.rubyonrails.org/upgrading_ruby_on_rails.html> ?

Thank you Hassan! You, Walter, and Colin have provided some great insight.