Anyone using the newest FCKeditor plugin

I did the install, followed the instructions and now getting a nil error:

eval):1:in `fckeditor_textarea': You have a nil object when you didn't
expect it!
The error occured while evaluating nil.full_description

I put the <%= javascript_include_tag "fckeditor/fckeditor" %> in the
layout , and then also tried it in the rhtml file where editor is to
go.

Here is my code:

<%= fckeditor_textarea("position", "full_description", :toolbarKit =>
'Simple', :width => '400', :height => '200') %>

position is the model and full_description is the method / column.

TIA
Stuart

I tried textarea and that gave me an error "undefined textarea"
So actually it's text_area, that works fine, either with w & h or rows and cols.

However fckeditor_textarea returns a nil error still ?
"nil.full_description"

Stuart

This happens because you need to define a model in whatever action is being
called if it isn't editing an existing one.

So if the action is post, then it should look like this

def post
  @position = Position.new()
end

Scott.