A Frustrated Beginner

I have tried everything in my power to get this program up and running
and it is not working for me. I have installed RoR on my Windows XP
machine. I have Instant Rails and Ruby on Rails and I am using Instant
Rails to connect the mySQL database to Ruby on Rails. It is not
working.

Everything works fine except when I create a scaffold it gives me an
error in mySQL.
The error reads,

"> ruby script/generate scaffold Product Admin
exists app/controllers/
exists app/helpers/
exists app/views/admin
exists app/views/layout
exists test/functional/
dependency model
exists app/models/
exists test/unit/
exists test/fixtures/
identical app/models/product.rb
identical test/unit/products.ywl
identical test/fixtures/product.yml
#28000Access denied for user 'root'@'localhost' (using password: NO)".

I have done this several time and continue to get the same error. Is
there anyone that can chat with me on an instant messenger or live
chat to help me with my problem, if possible.

My config/database.yml files shows,

# MySQL (default setup). Versions 4.1 and 5.0 are recommended.

It was the password thing. Bharat was correct. Thank you.