WEBrick development environment not reloading views in Windows

I recently RoR on a machine running Windows 2003 server. When I fire
WEBrick using the development environment, it does not reload the app
with changed views. I have to shut down WEBrick and restart it to see
the changes. Has anyone else had this problem?

Tom Brandt wrote:

I recently RoR on a machine running Windows 2003 server. When I fire
WEBrick using the development environment, it does not reload the app
with changed views. I have to shut down WEBrick and restart it to see
the changes. Has anyone else had this problem?

Just modifying the views should not require a webrick restart, but
changing anything in the models probably will require a webrick
restart.

Are you sure you're only changing the views and not something about the
models too?

Jeff
softiesonrails.com

Models do not need a restart in development mode, which is the one used by Tom. Views do not need a restart even in production mode, so there is something strange happening there.

This is a simple "Hello World!" application and there is no model, just
the controller and the view.

Tom Brandt wrote:

This is a simple "Hello World!" application and there is no model, just
the controller and the view.

Do you have the mongrel gem installed? I would recommend mongrel over
webrick anyway; and in Rails 1.2, it script/server will default to
mongrel if you have it installed.

Mongrel is easy to install on Windows, easy to start and stop, and I've
almost never had to restart it because of changes in my application
(only big things, like adding a database migration or something like
that).

gem install mongrel
gem install mongrel_service

Then from your rails app directory,

mongrel_rails start

will start up a webserver on port 3000 for you.

Jeff

Thanks, I'll try Mongrel.