ways of running functional tests

RichText wrote:

If I run all my tests using rake test, they all work. However, when I
run rake test:functionals, some functional tests fail on some of my
assertions? If I run the individual rb file in which the failing tests
appear, they work!

What is different between these ways of running functional tests? I've
been scratching my head over this one for ages!

Cheers.

Whenever I've had a problem like this it's been to do with the loading of fixtures -- and not loading all of them that were needed into a functional test (meaning the state of the items in the db depended on which tests were run prior to it, and in which order). Have a look at the functionals that are failing and make sure you are loading all the fixtures that are needed, including any tables they depend on.

HTH
Chris

i unsubscribed months ago and started getting rails email again today

this has happened once before.

wtf?

-- Elliot Temple
http://curi.us/dialogs/

Sorry for the inconvenience, you can unsubscribe by sending email to
rubyonrails-talk-unsubscribe@googlegroups.com