validates_date plugin for ActiveRecord

You are using an old version of the plugin. Try updating and let me
know is that fixes your problem.

-Jonathan.