Upgrading from Rails 1.2.6

I'm a Rails newbie. Currently my Mac is running Rails 1.2.6.

I would like to know how to upgrade to Rails 2.0.2. How do I ensure
my existing Rails apps are also upgraded?

Thanks

Your existing apps will not be upgraded after you upgrade your Rails
version.
You should upgrade them by hand.

First, modify your config/environment.rb
# Modify following line
# RAILS_GEM_VERSION = '1.2.6' unless defined? RAILS_GEM_VERSION
RAILS_GEM_VERSION = '2.0.2' unless defined? RAILS_GEM_VERSION

Then, save it and close it, run your terminal and go to the project
path and run the command:

rake rails:update

在 2009/7/9 上午 9:52 時, shusseina 寫到:

Thanks for that!