uninitialized constant ImageList

hey folks, ive been having this on-going problem that has pretty much
halted my development on my first project. It has consumed so much of
my time and ive been trying and trying to get my issue resolved, but
have not had any luck whatsoever.

I downloaded the rmagick zip file for WIN32 from the rmagick rubyforge
website. I installed the version intended for Ruby 1.8.4 / Rails 1.1.6
which is what im currently running on my localhost, using apache and
fastcgi. Everything is working, the application works, the tests for
image magick and rmagick both worked. When I try to use rmagick inside
my application Im getting the same error over and over and I cannot get
it fixed.

Exception Caught
NameError uninitialized constant ImageList

Now ive search google for days and only came up with people who have
problems on linux machines and no fixes for win32 machines.

How on earth do I fix this problem.. please someone help me so I can
finish my first application!!!

Thanks!!