Understand rails 2.0 and above

http://guides.rubyonrails.org/