Unable to configure apache 1.3.29 for ruby

janakiraman wrote:

Hi,

I downloaded Ruby(Version:1.8.2-15) from
http://apacheguide.org/ruby.php and followed the instruction given
there. Everything went fine till creating the Rails application. But
when I ran the command ruby "C:\Program Files\Apache
Group\Apache2\htdocs\myfirstapp\script\server" ,I get an error. Iam
unable to start WEBrick HTTP server. But on the other hand when I click
start->programs->ruby->ruby182-15->ruby gems->startrubygemsrdocserver
Iam able to start the WEBrick HTTP server. I could see the port number
as 8808. so I just went to the browser and type http://localhost:8808 I
don't get "congrulations,you've put ruby on rails" rather I get
"RubyGems Documentation Index".

Iam using apache 1.3.29 version.

Added the below set of lines to hhtp.conf

1)I added LoadModule fastcgi_module modules/mod_fastcgi.dll
2)I added AddModule mod_fastcgi.c
3)<VirtualHost *:80>
  ServerName rails
  DocumentRoot "E:\Projects\myfirstapp\public"
  <Directory "E:\Projects\myfirstapp\public">
    Options ExecCGI FollowSymLinks
    AllowOverride all
    Allow from all
    Order allow,deny
    AddHandler cgi-script .cgi
    AddHandler fastcgi-script .fcgi
  </Directory>
</VirtualHost>

Afer doing this and when I type http://localhost/ I get "Welcome aboard
You’re riding the Rails! Getting started Here’s how to get rolling:"

Iam not sure how to proceed next. Can anyone suggest me if iam in the
right direction and where I gone wrong.

Change your directory to "C:\Program Files\Apache Group\Apache2\htdocs\myfirstapp" then try running "ruby script/server".

Janakiraman Mr wrote:

Michael Wang wrote:

janakiraman wrote:

as 8808. so I just went to the browser and type http://localhost:8808 I
  ServerName rails

Afer doing this and when I type http://localhost/ I get "Welcome aboard
You?re riding the Rails! Getting started Here?s how to get rolling:"

Iam not sure how to proceed next. Can anyone suggest me if iam in the
right direction and where I gone wrong.

Change your directory to "C:\Program Files\Apache
Group\Apache2\htdocs\myfirstapp" then try running "ruby script/server".

--
Michael Wang

Thanks for your response. It was very useful. I did all the necessary changes and when I ran the app in the browser by typing http://localhost:3000/ I get a screen like this

Welcome aboard
You’re riding the Rails!
About your application’s environment
Getting started
Here’s how to get rolling:
Create your databases and edit config/database.yml
Rails needs to know your login and password.

Use script/generate to create your models and controllers
To see all available options, run it without parameters.

Set up a default route and remove or rename this file
Routes are setup in config/routes.rb.

Am I in the right direction? If so what is the next step that i should take. If not what is the necessary step that I should take to bring up the application.

Yes you are on the right track (heh). You should check out the screencasts and tutorials for Rails scattered around the Web or get one of the now many books for what to do next but basically like the above page says you need to create models and controllers (and views) and hook up your database.

As a trivial test of Rails itself you can do something like this at the shell prompt:

script/generate controller main index

Then rename, move or delete "public/index.html" and go to:

http://localhost:3000/main

and you should see this:

Main#index

Find me in app/views/main/index.rhtml

"main" is the name of the controller you generated with the script/generate controller command. By default if you just have the controller name in the URL it'll look for a method (called an "action" when its defined in a controller) called "index" defined in the controller and by default an action will render the .rhtml file of the same name in the app/views/<controller name> directory.