system hangs while running gem install rails

Hi,

My system hangs when I start "gem install rails --remote" command in
cli.
It is throwing message like "Bulk updating Gem source index for:
http://gems.rubyforge.org" and then hangs.

When I see FAQ 3.2 in 3rd chapter (http://docs.rubygems.org/read/
chapter/19), it is not answered. Even am facing the same issue.

Could you help me to resolve this issue?

Thanks

Thanks Andrew,

Today I have tried again running the same command but no positive
result. I had waited for about 1 Hr.

Let me brief you what I have done

1. Installed "ruby186-25"
2. Openned the command prompt.
3. Ran "gem install rails -r"

Am I missing any?

Ram

Got the solution in another way.
Just downloaded the Rails package and copied to c drive.
Ran the server script and now i can open the default page at
127.0.0.0:3000

Thanks
Ram

Hi,

I thought the problem was solved but not. I can open the firsrt page
http://127.0.0.1:3000, but when I create new controller and try to
access that page it is giving Routing Error no route found to
match..........

am summarizing what i did

1. Installed ruby - ruby186-25.
2. Not able to succed the command "gems installs rails --remote OR --
include-dependencies"
3. Then I downloaded the rails package - rails-1.2.5.
4. Error was coming when stating the default server WEBrick with the
command "ruby script/server" from the file environment.rb at line 8 as
<%= '# ' if freeze %>RAILS_GEM_VERSION = '<%= Rails::VERSION::STRING
%>' unless defined? RAILS_GEM_VERSION.
5. The error was unexpected, "<" at the very beginning. Then I removed
the < and ran the server, it was fine.
6. Then I created one controller "ruby script/generate controller
MyTest" and it was success.
7. When I try to open http://127.0.0.1:3000:MyTest, throws Routing
Error.

Could you help me to fix this error?