Strange problem... action content disappears after a while

Hi All,

I am experiencing a very strange problem today. I’m on edge rails and after a few minutes after a server resart my action content doesn’t get rendered (just the layout is served) by rails. I am using coda hales mongrel + apache 2.2 setup. I have also reproduced this problem locally with a single mongrel. It occurs anywhere from 1 to 25 minutes after the server starts. I disabled page caching and a couple of plugins I was using but it’s still happening. The logs seem identical to when the content is properly rendered. I haven’t yet reproduced this problem with webrick but that could just be because it’s so intermittent… I’ll keep trying.

Has anyone experienced this before? Any ideas on where to begin looking?

Thanks,
Sean

What OS? What database? Which gems.plugins are you using?

i am asking because I had a similar problem with an incorrect
installation of sqlite3 which apparently resulted in some bizarre
memory corruption that led to similar symptoms.

Max

Hi Max,

On my dev box I’m using OS X 10.4 with MySQL 4.1. On the production server it’s Fedora Core 4 again with MySQlL 4.1. The installed gems and plugins for both are listed below. I think the issue must be rails related beacuse it only started to happen when I upddate my copy of edge rails today, which I hadn’t updated for maybe a month. This evening I rolled back to revision 5214 and that seems that have solved the problem for now so I strongly suspect some issue with edge rails or perhaps with other software below that worked fine until some change to rails.

Thanks,
Sean

Plugins:

active_merchant
dynamic_session_expiry
error_messages_for
file_column
form_remote
gruff
reverse_proxy_fix
ssl_requirement
textmate_footnotes

Gems:

*** LOCAL GEMS ***

actionmailer (1.2.4, 1.2.3, 1.1.5)
Service layer for easy email delivery and testing.

actionpack (1.12.4, 1.12.3, 1.11.2)
Web-flow and rendering framework putting the VC in MVC.

actionwebservice (1.1.5, 1.1.4, 1.0.0)
Web service support for Action Pack.

activerecord (1.14.4, 1.14.3, 1.13.2)
Implements the ActiveRecord pattern for ORM.

activesupport (1.3.1, 1.2.5
)
Support and utility classes used by the Rails framework.

daemons (0.4.4)
A toolkit to create and control daemons in different ways

fcgi (0.8.6.1)
FastCGI ruby binding.

gem_plugin (0.2.1)
A plugin system based only on rubygems that uses dependencies only

hpricot (0.4)
a swift, liberal HTML parser with a fantastic library

money (1.7.1)
Class aiding in the handling of Money.

mongrel (0.3.13.4, 0.3.13.3)
A small fast HTTP library and server that runs Rails, Camping, and
Nitro apps.

mongrel_cluster (0.2.0)
Mongrel plugin that provides commands and Capistrano tasks for
managing multiple Mongrel processes.

mongrel_upload_progress (0.2)
The mongrel_upload_progress GemPlugin

mysql (2.7)
MySQL/Ruby provides the same functions for Ruby programs that the

MySQL C API provides for C programs.

paypal (2.0.0)
Paypal IPN integration library for rails and other web applications

rails (1.1.5, 1.1.4, 1.0.0)
Web-application framework with template engine, control-flow layer,

and ORM.

rake (0.7.1, 0.7.0)
Ruby based make-like utility.

RedCloth (3.0.3)
RedCloth is a module for using Textile and Markdown in Ruby. Textile
and Markdown are text formats. A very simple text format. Another

stab at making readable text that can be converted to HTML.

rmagick (1.10.0)
RMagick is an interface between the Ruby programming language and
the ImageMagick and GraphicsMagick image processing libraries.

ruby-mp3info (0.5)
ruby-mp3info is a pure-ruby library to retrieve low level
informations on mp3 files and manipulate id3v1 and id3v2 tags

sources (0.0.1)

Hi,

The problem is stil ocurring with revision 5214. I haven’t been able to repeat it under webrick, so I wonder if it’s related to mongrel. Does anyone have any ideas about what it could be? I don’t think it’s DB related because it’s happening on pages without any DB content.

Thanks,
Sean