SSL

My guess is that you're using url_for() to redirect and that Rails
itself isn't managing the SSL but some other process on your server
(pound, in our case).

So, for us, and I'm guessing you too, Rails has no idea it's behind an
SSL connection. That that means that url_for generates a http: path
instead of https:.

If this is all true for you, you can use path_for instead of url_for.
path_for generates a relative path instead of a full url including the
protocol, which if linking inside your application, should work fine.
Another option is to pass the :only_path => true argument to url_for. A
third option is to just pass a hash to redirect_to, such as...

redirect_to :controller => 'people', :action => 'show', :id => @person.id

And lastly, if you're using RESTful routes, you can just...

redirect_to person_path(@person)

felipekk@gmail.com wrote: