Sprockets 2.0.0.beta.11 breaks assets

Hello!

I'm really not sure what the change was the broke it, but rails
3.1.0.rc4 with the version of sprockets that just got tagged today
(2.0.0.beta.11) no longers works with the assets pipeline. I get the
following errors in my server logs:

I am having the same problem with sprockets 2.0.0.beta.11. The assets
are not getting generated. Rolling back to beta 10 solves the problem.

Have you tried cloning this into a local dir and specifying that as a path like this:

gem ‘sprockets’, :path => “vendor/sprockets”

And then attempt to run a git bisect over that directory to figure out what, if anything, broke between beta10 and beta11? I mean, you do have good and bad refs to start from.

Oh, and I can confirm this issue.

I would have thought this would have been picked up before beta11 was released, given it’s basically the functionality in Sprockets.

I ran a bisect and found this:

4b7afcc3553c149261f457c3de88ff9d5458a3f6 is the first bad commit

commit 4b7afcc3553c149261f457c3de88ff9d5458a3f6

Author: Joshua Peek josh@joshpeek.com

Create Base class for Environment and Index

:040000 040000 5423b6f2fc31d6834207ada0252fa2e61086be74 0b0396b560ccb5947bf5c47668e6629c7c60e525 M lib

:040000 040000 112d4ec7a3a494c29693546cc19abb2a1ba4e475 8fe7693a9440ae64fd7ae79dc37f7cf5e4607ae4 M test

I’m not quite sure how to narrow the problem down further. There were quite a lot of changes in that commit.

I have the same problem, too, Anurag, how do you roll back to beta 10,
I try doing that in the Gemfile, but it says that it cannot find
2.0.0.beta.11 (?!) and just gives up instead of installing and using
2.0.0.beta.10

Nik: Specify this line in your Gemfile:

gem ‘sprockets’, ‘2.0.0.beta10’

Make sure there isn’t one there for 2.0.0.beta11 or anything else mentioning sprockets.

Then run bundle update sprockets. This will change it to the correct version.

Even with beta10, sprockets are not working with 3-1-stable rails branch

https://github.com/rails/rails/issues/1822

This issue seems to have been fixed in Rails RC5. Add this line to
your Gemfile.

gem 'rails', '3.1.0.rc5'

We don't have to override the version of sprockets now. The version
that is picked up by default is sprockets-2.0.0.beta.12, which seems
to contain a fix.