Segmentation Fault after upgrade 1.9

Hi Guys,

I've just upgraded to 1.9.1p243.

Everything in installation is fine EXCEPT it CANNOT RUN.

I downloaded the source and then
./configure --prefix=...
sudo make
sudo make install
(then reboot)

And when I run "ruby -v"
Segmentation Fault

My OS is ubuntu 9.1. Can anyone gimme some clue?

thanks
Arthur