script/generate cucumber fails in Rails 2.3.5 and Ruby 1.9.1

thanks eric,

that’s what I saw before you mailed. It’s so late and I’m coding for over 12 hours you know. Of course it cucumber-rails. Sorry just copied & pasted it => stupid_me.

Chris

Guys,

Dont lose focus. =)

The problem is that the script/generate cucumber doesn’t work, it reports this error.

my config/environments/tests.rb looks like this now.

config.gem “rspec”, lib => false, :version => “>=1.2.9”
config.gem “rspec-rails”, lib => false, :version => “>=1.2.9”
config.gem “webrat”, lib => false, :version => “>=0.6.0”
config.gem “cucumber”, lib => false, :version => “>=0.5.3”
config.gem “cucumber-rails”, lib => false, :version => “>=0.2.2”

I’m still facing the problem.

/var/lib/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require’: no such file to load – cucumber/platform (MissingSourceFile)

from /var/lib/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `block in require'
from /var/lib/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in `new_constants_in'

from /var/lib/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'
from /var/lib/gems/1.9.1/gems/cucumber-rails-0.2.2/generators/cucumber/cucumber_generator.rb:2:in `<top (required)>'

from /var/lib/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'
from /var/lib/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `block in require'

from /var/lib/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in `new_constants_in'
from /var/lib/gems/1.9.1/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'

from /var/lib/gems/1.9.1/gems/rails-2.3.5/lib/rails_generator/spec.rb:17:in `klass'
from /var/lib/gems/1.9.1/gems/rails-2.3.5/lib/rails_generator/lookup.rb:140:in `instance'
from /var/lib/gems/1.9.1/gems/rails-2.3.5/lib/rails_generator/scripts.rb:31:in `run'

from /var/lib/gems/1.9.1/gems/rails-2.3.5/lib/commands/generate.rb:6:in `<top (required)>'
from script/generate:3:in `require'
from script/generate:3:in `<main>'

[]'s
Rodrigo Dellacqua