ruy 1.8.6 and rails 2.3.5

Hi
  I have ruby version
ruby 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32] and rails 2.3.5 on
machine .Now i have created a new rails project and setup dataase.yml
When issue
rake db:create I get error

c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/active_record/connection_a
dapters/mysql_adapter.rb:202: [BUG] Segmentation fault
ruby 1.8.6 (2007-09-24) [i386-mswin32]

This application has requested the Runtime to terminate it in an unusual
way.
Please contact the application's support team for more information.
    What cause this error.Please help

Thanks in advance
Tom