Runtime error.

Hello everybody.

I just upgrade my gem version 1.37 to 1.8.11. Then i run my project and got a this error.



I don't believe you listed your entire gem list - important things
like activerecord, actionmailer, etc. are missing. You should have a
json gem. Try updating it. (gem update json)

Sorry .

My gem list is.

Just upgrade to the latest edge Rails version to anything >= v2.3.10. This solves the problem. (There is a ‘threads’ dependency in the stack which causes this error).

If you cannot upgrade your Rails version, you would need to downgrade the gem version.


  • Gautam

thats right its a gem versiion problem, downgrade it

Enviado via iPad

Thanks all. This problem is solved.