Ruby on rails and apache 2.2.3

Just a shot in the dark, the two tutorials you link to instruct you to
edit httpd.conf to use "LoadModule fastcgi_module
modules/mod_fastcgi.dll" but your error seems to be looking for a .so
file, not .dll. Maybe that has nothing to do with it, or you've already
included the correct line in httpd.conf. I've not yet deployed with
Apache yet and I do all of my development on Ubuntu Linux, so I don't
know if I can help beyond the suggestion above.

Good luck,
John-Scott

P.S. I had to roll back the RoR wiki page you linked to...it had
already been spammed a few times between the time of your post and when
I looked at it!