Ruby-GetText-Package-1.92.0

Hi,

Ruby-GetText-Package-1.92.0 is now available.

Changes

I am getting the following now with edge rails:

Loading development environment (Rails 2.1.0)
/Library/Ruby/Gems/1.8/gems/gettext-1.92.0/lib/gettext/
active_record.rb:238:NameError: uninitialized class variable
@@default_error_messages in ActiveRecord::Errors
/Library/Ruby/Gems/1.8/gems/gettext-1.92.0/lib/gettext/rails.rb:25:
warning: already initialized constant Rails
/Library/Ruby/Gems/1.8/gems/gettext-1.92.0/lib/gettext/rails.rb:432:
warning: already initialized constant MESSAGESS
/Library/Ruby/Gems/1.8/gems/gettext-1.92.0/lib/gettext/rails.rb:433:
warning: already initialized constant NMINUTES
/Library/Ruby/Gems/1.8/gems/gettext-1.92.0/lib/gettext/rails.rb:434:
warning: already initialized constant NHOURS
/Library/Ruby/Gems/1.8/gems/gettext-1.92.0/lib/gettext/rails.rb:435:
warning: already initialized constant NDAYS
/Library/Ruby/Gems/1.8/gems/gettext-1.92.0/lib/gettext/rails.rb:436:
warning: already initialized constant NMONTHS
/Library/Ruby/Gems/1.8/gems/gettext-1.92.0/lib/gettext/rails.rb:437:
warning: already initialized constant NYEARS
/Library/Ruby/Gems/1.8/gems/gettext-1.92.0/lib/gettext/
active_record.rb:238:NameError: uninitialized class variable
@@default_error_messages in ActiveRecord::Errors

In fairness, once I did rake rails:freeze:edge I got the same with
1.91.0

Hi,

How about to use config.gem instead of requiring
gettext/rails directly?

In environment.rb:
Rails::Initializer.run do |config|
   :
   :
  config.gem "gettext", :lib => "gettext/rails" # This line
end

It works for me with Rails-2.1.0(not edge rails)

That definitely helps, and it knocks me down to just:

/Library/Ruby/Gems/1.8/gems/gettext-1.92.0/lib/gettext/
active_record.rb:238:NameError: uninitialized class variable
@@default_error_messages in ActiveRecord::Errors

Hi,

I see.
You use edge rails, not 2.1.0.

I think active_record i18n part breaks
their background compatibility and
ruby-gettext occurs the error.

Try to use 2.1.0.