Ruby 1.9 compatability fix - sum

Hi !
Heres small, tiny update needed for potionstore on ruby 1.9. Its the
activesupport / core_ext / enumerable / 'sum' function. This one
reared its ugly head when loading the list of layout files on startup.
I'm guessing its not commonly reproduced in many rails apps, but it
did break the potionstore app (any perhaps others under the 1.9
environment).

If interested please come see the patch at lighthouse:
https://rails.lighthouseapp.com/projects/8994-ruby-on-rails/tickets/2776

dreamcat4
dreamcat4@gmail.com