RMagick installation on 64bit ubuntu 7.04

Dear All,

Thanks in advance !

i have ubuntu 7.04 64 bit installed... i want to install RMagick 2.5 and
i have done that installation but it is working ?

here are some outputs

Dear All,

Thanks in advance !

i have ubuntu 7.04 64 bit installed... i want to install RMagick 2.5 and
i have done that installation but it is working ?

Have you tried actually using it?

--------------------------------------------------------------------------- ----
root@bpocanada-desktop:/home/bpocanada/test2# irb
irb(main):001:0> require 'RMagick'
LoadError: no such file to load -- RMagick
from (irb):1:in `require'
from (irb):1
irb(main):002:0> exit

it's a gem, so if you don't load rubygems then you can't require it

Here anything missing like PATH of some directories ?

and when i do irb -rubygems -r RMagick instead of irb ? like following !

--------------------------------------------------------------------------- -----
root@bpocanada-desktop:/home/bpocanada/test2# irb -rubygems -r RMagick
irb(main):001:0> require 'RMagick'
=> false
irb(main):002:0>

Here it should be True ? or False ?

if the require doesn't through an exception it means that the library
has been loaded (or in this case was already loaded)

Fred

Frederick Cheung wrote:

Have you tried actually using it?

Hey i am a Linux admin and i have been given task to solve the RoR
developers issus and it is their issu! They told me that the out put of
the following

root@bpocanada-desktop:/home/bpocanada/test2# irb -rubygems -r RMagick
irb(main):001:0> require 'RMagick'
=> false
irb(main):002:0>

should be True fot them to use it ! and i have to solve this as it is
false right now !

so .............

Frederick Cheung wrote:
>Have you tried actually using it?

Hey i am a Linux admin and i have been given task to solve the RoR
developers issus and it is their issu! They told me that the out put of
the following

root@bpocanada-desktop:/home/bpocanada/test2# irb -rubygems -r RMagick
irb(main):001:0> require 'RMagick'
=> false
irb(main):002:0>

should be True fot them to use it ! and i have to solve this as it is
false right now !

They're wrong. You're requiring it twice (once with the -r flag, once
explicitly), so it's perfectly normal for the second require to return
false because require won't load the same path twice.

Fred

Frederick Cheung wrote:

irb(main):002:0>

should be True fot them to use it ! and i have to solve this as it is
false right now !

They're wrong. You're requiring it twice (once with the -r flag, once
explicitly), so it's perfectly normal for the second require to return
false because require won't load the same path twice.

Fred

OK i understand what u want to say but ...
if i do following command then ( irb with out any -r option to load
RMagick) and then if i do require 'RMagick' then it will give me like
following !!! why ?

root@bpocanada-desktop:/home/bpocanada/test2# irb
irb(main):001:0> require 'RMagick'
LoadError: no such file to load -- RMagick
        from (irb):1:in `require'
        from (irb):1
irb(main):002:0> exit

Frederick Cheung wrote:

irb(main):002:0>

should be True fot them to use it ! and i have to solve this as it
is
false right now !

They're wrong. You're requiring it twice (once with the -r flag, once
explicitly), so it's perfectly normal for the second require to
return
false because require won't load the same path twice.

Fred

OK i understand what u want to say but ...
if i do following command then ( irb with out any -r option to load
RMagick) and then if i do require 'RMagick' then it will give me like
following !!! why ?

because you need to require rubygems first.

Fred

Frederick Cheung wrote: