RMagick gem require error

When I try the following in my User model - require 'RMagick'

I get the following error:

127: The specified procedure could not be found. -
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdp-rmagick-0.0.0/lib/RMagick2.so

I've been to the directory and the RMagick2.so file exists

After a bit or reading I think it has something to do with the
libMagickWand.so.1 file but I cannot find it anywhere.

I've already tried reinstalling ImageMagick and the RMagick gem (2.12.0
win32) so completely at a loss.

Anyone have any ideas?
Thanks!