Revision: Background image contained in stylesheet

I realized that I should have included a bit more information in my
previous post, so here's the revision.

application.html.erb is correctly finding the stylesheet for my project
via <%= stylesheet_link_tag 'style1' %>. My webpages reflect the
styling properly with a few exceptions .. the most notable being some
.jpg images defined for background do not display at all. I have those
images in public/images.

The following is the stylesheet code containing the reference to the
image.

#navigation {
  width: 180px;
  height: 484px;
  background: #7da5a8 url(nav-bg.jpg) no-repeat;
}

I tried the absolute path to the image above per: background: #7da5a8
url(C:\InstantRails\rails_apps\getdowninthevalley\public\images\nav-bg.jpg)
no-repeat; but that didn't work either

This worked fine until I retrofitted the webpages into the Rails
framework (which I really like, but which I'm relative new to).

If anyone knows the solution, I would really appreciate it ... thanks in
advance!

Rubio

I realized that I should have included a bit more information in my

previous post, so here’s the revision.

application.html.erb is correctly finding the stylesheet for my project

via <%= stylesheet_link_tag ‘style1’ %>. My webpages reflect the

styling properly with a few exceptions … the most notable being some

.jpg images defined for background do not display at all. I have those

images in public/images.

The following is the stylesheet code containing the reference to the

image.

#navigation {

width: 180px;

height: 484px;

background: #7da5a8 url(nav-bg.jpg) no-repeat;

}

Your path needs to specify the full relative path.

url(/images/nav-bg.jpg)

Looks like you’re missing ‘images/’