restful_authentication issues in production

I'm not sure what's going on here, but password resets with
restful_authentication aren't working in production. However, they
are working in development and staging.

The request to the passwords controller's create action is completing
successfully according to the server log:

Processing PasswordsController#create (for 68.107.52.195 at 2009-03-01
14:36:29) [POST]
  Parameters: {"commit"=>"Reset Password",
"authenticity_token"=>"a31cf1ba526601835092b65a6b471e9f134cee59",
"email"=>"gavin.todes@gmail.com"}
Redirected to /login
Completed in 592ms (DB: 149) | 302 Found [http://www.mysite.com/
password]

However, no password reset code is set in the DB and no email is
delivered.

The only account on the production app is the administrator account
because I haven't yet opened it up for signups, and like an idiot I
forgot my password so I'm not even sure if logging in works in
production.

What gives?

I just manually set the password reset code in the DB. I then tried
to reset the password and it didn't work. What's going on?

Did you have any luck solving this? I'm having the exact same problem
and can't figure how to fix it.

silly me.
In my passwords controller:

def create
    return unless request.post?
    if @user = User.find_by_email(params[:email])
    @user.forgot_password
    @user.save
    .....
end

All I did was add "!" to @user.save, and now it works.