Remote install of 1.2.6

Hello,

Any help would be much appreciated as I am a total newbie. I know this
topic has come up before, but I am still struggling with it.

I am trying to do a remote install of 1.2.6 because I bought a couple of
books based on 1.2.x and I do not want to have to wrestle with errors
caused by having a 2.x version while I am a rank beginner and trying to
learn.

I keep getting an error message:
ERROR: could not find rails locally or in a repository

When I go to gems.rubyforge.org and follow the link to see the available
gems in my browser, it clearly shows all the old versions. However, if
I do a gem list command, only 2.0.2.

It appears the older versions are no longer hosted for remote
installation. Would somebody mind helping me with detailed instructions
on manually installing an older version, including where to get and
where to put all the files? Better yet, if there is a way to use gem to
find and remotely install them, I would appreciate those instructions as
well. Finally, why aren't the old versions hosted anymore?

One last thing... I am using Windows. I know, I know... but I am only
in the very early stages of teaching myself FreeBSD, and I trying to
reduce the number of variables in learning that, Ruby, and Rails all at
the same time.

Again, many thanks.

Harry

Have you tried:

gem install rails --version 1.2.6

I see all the gems still here: http://rubyforge.org/frs/?group_id=307

Charles,

When I do that (gem install rails --version 1.2.6) I get the following:
ERROR: could not find rails locally or in a repository

and when I do the following:
gem list rails --remote
I get the following output in the list:
...
rails (2.0.2)
...

There seems to be a discrepancy between what is listed as being
available and what actually is.

Any other suggestions?

Thanks for your help... it is much appreciated.

Harry

Charles Quinn wrote:

Harry Weeds wrote:

Charles,

When I do that (gem install rails --version 1.2.6) I get the following:
ERROR: could not find rails locally or in a repository

and when I do the following:
gem list rails --remote
I get the following output in the list:
...
rails (2.0.2)
...

There seems to be a discrepancy between what is listed as being
available and what actually is.

Any other suggestions?

gems.rubyforge.org contains a link to the gems themselves. They are
available, but somehow gem doesn't see them (had that happen to me, too,
just an hour ago).

Just download what you need, and gem install rails-1.2.6.gem will do the
rest (of course, done in the directory you downloaded the gems to).

- --
Phillip Gawlowski
Twitter: twitter.com/cynicalryan

~ - You know you've been hacking too long when...
...you count empty bottles (two at a time) like this:
"2, 4, 8, 16, 32, .... 32?!?"

Phillip,

Success, I think.

I downloaded it to the following path (I am running it off a flash
drive):
F:\PortableApps\RubyPortable\App\Ruby\lib\ruby\gems\1.8\gems\rails-1.2.6>

I am not sure if that is the correct locaton, but it seems to work.
Aside from continually telling me it needed other gems (i.e.
actionmailer <= 1.3.6), and only generating documentation for rails and
actionmailer, everything seems to be fine.

Thank you very much for your help.

Harry

Phillip Gawlowski wrote:

Harry Weeds wrote:

Phillip,

Success, I think.

I downloaded it to the following path (I am running it off a flash drive):
F:\PortableApps\RubyPortable\App\Ruby\lib\ruby\gems\1.8\gems\rails-1.2.6>

I am not sure if that is the correct locaton, but it seems to work.

Depends: If it's the downloaded gems, it doesn't really matter. :stuck_out_tongue:

If the rails gem are installed there, that is the correct directory.

Thank you very much for your help.

No problem. Glad it' solved for you. :slight_smile: