rake db:migrate will not migrate

This has always worked previously. I have not changed anything with my database config. I am able to use the credentials in the database.yml file when using mysql -u....

Here is the problem:

$ rake db:migrate (in /Users/siddeeqm/Documents/development/qadepot/trunk)

$ rake db:migrate version=5 (in /Users/siddeeqm/Documents/development/qadepot/trunk)

$ ruby script/about About your application's environment Ruby version 1.8.6 (i686-darwin8.10.3) RubyGems version 0.9.2 Rails version 1.2.3 Active Record version 1.15.3 Action Pack version 1.13.3 Action Web Service version 1.2.3 Action Mailer version 1.3.3 Active Support version 1.4.2 Application root /Users/siddeeqm/Documents/development/ qadepot/trunk Environment development Database adapter mysql Database schema version 11

$ ls db/migrate/ 001_create_qa_tags.rb 007_create_qa_step_flags.rb 002_create_qa_plans.rb 008_create_qa_runs.rb 003_create_qa_cases.rb 009_create_qa_results.rb 004_create_qa_steps.rb 010_create_qa_jira_tickets.rb 005_create_qa_assignments.rb 011_create_qa_pictures.rb 006_create_qa_run_statuses.rb

Try using VERSION=5 (note the uppercase)


Rob Biedenharn http://agileconsultingllc.com Rob@AgileConsultingLLC.com

Brilliant!! That worked. Not sure why I thought the lowercase would work.

Musa S.