Rails server start show error

Hi all,

ruby: 1.9.2
rails: 3.2.3
OS: redhat5

I create a new rails project. --> 'rails proj3'

I exec "rails server" want to check it can start or not,

but it show below error message.

CC Chen wrote in post #1055038:

Hi all,

ruby: 1.9.2
rails: 3.2.3
OS: redhat5

I create a new rails project. --> 'rails new proj3'

I exec "rails server" want to check it can start or not,

but it show below error message.

*************************************************

/usr/local/ruby/lib/ruby/gems/1.9.1/gems/railties-3.2.3/lib/rails/script_rails_loader.rb:11:

warning: Insecure world writable dir /home/u337user/gavin in PATH, mode
040777

/usr/local/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:211:

warning: Insecure world writable dir /home/u337user/gavin in PATH, mode
040777

/usr/local/ruby/lib/ruby/gems/1.9.1/gems/execjs-1.3.0/lib/execjs/runtimes.rb:50:in

`autodetect': Could not find a JavaScript runtime. See
https://github.com/sstephenson/execjs for a list of available runtimes.
(ExecJS::RuntimeUnavailable)
        from
/usr/local/ruby/lib/ruby/gems/1.9.1/gems/execjs-1.3.0/lib/execjs.rb:5:in
`<module:ExecJS>'
        from
/usr/local/ruby/lib/ruby/gems/1.9.1/gems/execjs-1.3.0/lib/execjs.rb:4:in
`<top (required)>'
        from

/usr/local/ruby/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee_script.rb:1:in

`require'
        from

/usr/local/ruby/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee_script.rb:1:in

`<top (required)>'
        from

/usr/local/ruby/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee-script.rb:1:in

`require'
        from

/usr/local/ruby/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee-script.rb:1:in

`<top (required)>'
        from

/usr/local/ruby/lib/ruby/gems/1.9.1/gems/coffee-rails-3.2.2/lib/coffee-rails.rb:1:in

`require'
        from

/usr/local/ruby/lib/ruby/gems/1.9.1/gems/coffee-rails-3.2.2/lib/coffee-rails.rb:1:in

`<top (required)>'
        from

/usr/local/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:68:in

`require'
        from

/usr/local/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:68:in

`block (2 levels) in require'
        from

/usr/local/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:66:in

`each'
        from

/usr/local/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:66:in

`block in require'
        from

/usr/local/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:55:in

`each'
        from

/usr/local/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:55:in

`require'
        from
/usr/local/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler.rb:119:in
`require'
        from
/home/u337user/gavin/rails_project/proj3/config/application.rb:7:in
`<top (required)>'
        from

/usr/local/ruby/lib/ruby/gems/1.9.1/gems/railties-3.2.3/lib/rails/commands.rb:53:in

`require'
        from

/usr/local/ruby/lib/ruby/gems/1.9.1/gems/railties-3.2.3/lib/rails/commands.rb:53:in

`block in <top (required)>'
        from

/usr/local/ruby/lib/ruby/gems/1.9.1/gems/railties-3.2.3/lib/rails/commands.rb:50:in

`tap'
        from

/usr/local/ruby/lib/ruby/gems/1.9.1/gems/railties-3.2.3/lib/rails/commands.rb:50:in

`<top (required)>'
        from script/rails:6:in `require'
        from script/rails:6:in `<main>'
************************************************************

I recently should move the ROR server to redhat5 from winXP.

In WinXP, I didn't see those problems.

Does someone can give me a help?

Thanks,

I solved this problem by add "gem 'execjs'" and "gem 'therubyracer'"

Thanks,

Installing Nodejs might be best but Gems mentioned here are also solve
this problem:
$ gem install execjs therubyracer