Rails problem

# gem list

*** LOCAL GEMS ***
..
rails (2.3.2, 2.3.0, 2.2.2)
..

# gem env gempath
/root/.gem/ruby/1.8:/usr/lib/ruby/gems/1.8

./config/environment.rb
...
RAILS_GEM_VERSION = '2.3.2' unless defined? RAILS_GEM_VERSION
...

# ./script/generate controller test
Missing the Rails 2.3.2 gem. Please `gem install -v=2.3.2 rails`, update
your RAILS_GEM_VERSION setting in config/environment.rb for the Rails
version you do have installed, or comment out RAILS_GEM_VERSION to use
the latest version installed.

What wrong?

...
RAILS_GEM_VERSION = '2.3.2' unless defined? RAILS_GEM_VERSION
...

# ./script/generate controller test
Missing the Rails 2.3.2 gem. Please `gem install -v=2.3.2 rails`, update
your RAILS_GEM_VERSION setting in config/environment.rb for the Rails
version you do have installed, or comment out RAILS_GEM_VERSION to use
the latest version installed.

What wrong?

I'd guess you have several versions of ruby installed.

Fred

Frederick Cheung wrote:

I'd guess you have several versions of ruby installed.

There was ruby 1.9 istalled, but not any more.

Help?