Rails on OS X problem

Hi All,

So far I have been unable to get rails working on a 10.5.6 OS X
installation. Every 'rails' command ends with the following error:

/Library/Ruby/Site/1.8/rubygems.rb:827:in `report_activate_error':
RubyGem version error: ruby-openid(2.1.7 not ~> 2.0.0)

I tried uninstalling and then re-installing ruby-openid, but that
doesn't help. Working with rails on Windows and Linux machines was
never a problem, but this one has me baffled.



What does `gem list --local ruby-openid` produce?

and "~> 2.0.0" is the pessimistic version matcher. It is equivalent to:

">= 2.0.0", "< 2.1"

So 2.1.7 does not satisfy the requirement. Typically, this version matcher is used when there is a known incompatibility with a later version. Presumably, you can find where the 'gem "ruby-openid", "~> 2.0.0"' is located and determine if *that* code has a more recent version.

Alternatively, you could try:

gem install ruby-openid -v "~>2.0.0"


Rob Biedenharn http://agileconsultingllc.com