Rails on nginx/passenger/xubuntu error

I just installed latest rails, passenger, nginx on xubuntu.

I deployed a static app (myapp) on port 80 and it seems to work fine.
I installed fast-cgi and deployed phpmyadmin on 8888 which works fine.
Then I tried to deploy a rails app (test) to port 8484, and it didn't
work. I simply copied my rails apps files to /var/www/test/current
directory for the deployment. Since 8484 didn't work, I changed the
port of the rails app to 80 (previously held by static myapp) and
switched myapp to 8484. Now when I hit http://localhost it keeps
taking me to the index.html page of myapp, no sign of the rails app.

here is my nginx.conf files, not sure if this is a passenger issue or
nginx problem.

The rails app (simple hello world), works just fine in dev.

#user nobody;
worker_processes 1;

#error_log logs/error.log;
#error_log logs/error.log notice;
#error_log logs/error.log info;

#pid logs/nginx.pid;

events {
    worker_connections 1024;

}

http {
    passenger_root /usr/lib/ruby/gems/1.8/gems/passenger-2.2.11;
    passenger_ruby /usr/bin/ruby1.8;

    include mime.types;
    default_type application/octet-stream;

    #log_format main '$remote_addr - $remote_user [$time_local]
"$request" '
    # '$status $body_bytes_sent "$http_referer" '
    # '"$http_user_agent" "$http_x_forwarded_for"';

    #access_log logs/access.log main;

    sendfile on;
    #tcp_nopush on;

    #keepalive_timeout 0;
    keepalive_timeout 65;

    #gzip on;

#for test
    server {
        listen 80;
        server_name localhost;

        #charset koi8-r;

        access_log logs/test.access.log;
        error_log logs/test.error.log;

        #location / {
            rails_env development;
            root /var/www/test/current/public;
            passenger_enabled on;
            #index index.html index.htm;
        #}

        error_page 404 /404.html;

        # redirect server error pages to the static page /50x.html