rails environment suuuper slow

ever since i started using rails 3 everything take ages to load, and
no one seems to know the reason

ubuntu 10.04
rvm
ruby 1.9.2
rails 3.0.1

and i get this

time rspec spec/models/user_spec.rb
...

Finished in 0.80685 seconds
3 examples, 0 failures

real 0m19.700s
user 0m18.045s
sys 0m1.332s

as you can see the test takes less than a second but the process takes
20 seconds, this is driving me crazy.

these are the gems im using
gem ‘rails’, ‘3.0.1’

gem ‘sqlite3-ruby’, :require => ‘sqlite3’
gem “will_paginate”, “>=3.0.pre2”
gem “devise”, “>=1.1.2”
gem “devise_invitable”
gem “formtastic”, “>=1.1.0”
gem “friendly_id”, “~>3.0”
gem “compass”, “>= 0.10.5”
#gem “metric_fu”, “>=1.5.1”, :group => :development
gem “rspec”, “>=2.0.0”, :group => :test
gem “rspec-rails”, “>=2.0.0”, :group => [:development, :test]
#gem ‘autotest-rails’, :group => [:development, :test]
gem “remarkable”, “>=4.0.0.alpha4”, :group => :test
gem “remarkable_activemodel”, “>=4.0.0.alpha4”, :group => :test
gem “remarkable_activerecord”, “>=4.0.0.alpha4”, :group => :test
gem “shoulda”, :group => :test
gem “faker”, :group => [:test, :cucumber]
gem “factory_girl_rails”
gem “cucumber”, “>=0.6.3”, :group => :cucumber
gem “cucumber-rails”, “>=0.3.2”, :group => :cucumber
gem “capybara”, “>=0.3.6”, :group => :cucumber
gem “database_cleaner”, “>=0.5.0”, :group => :cucumber
gem “spork”, “>=0.8.4”, :group => :cucumber
gem “pickle”, “>=0.4.2”, :group => :cucumber
gem “selenium-webdriver”
gem “inploy”, “>=1.6.8”
gem “rails3-generators”, :git => “git://github.com/indirect/rails3-generators.git
gem ‘simple-navigation’, ‘3.0.0’
gem “cancan”
gem “launchy”, :group => :cucumber

rvm is 1.0.17

anyone?

Have you cleared out your development log file?

yes , an op top of it all, everything is as slow even rake, the app is not very all i have only worked on it for a month