rails console and tests launch time too long?

When I run script/console I have to wait like 10 seconds to the console
to start.

When I run any of the tests in my rails app ('rake test' or whatever
else like AltShiftX+U in RadRaild) I also have to wait about
7-10 seconds for the testing itself to start.

This slows down my continues-development cycle. Is there any way to
speed up tests-framework startup in rails 2.3.5, 2.3.9 and ruby 1.8.7?

I would like the testing framework to startup in max 1 second. I am
doing TDD and I run tests several tomes a minute sometimes. If the
testing framework starts up 10 seconds it is not acceptable for me.

Thanks!
M.

just a thought, if you close radrails, does it improve the speed if you open a rails console in a terminal session? i don't know what system you are on, but my kubunutu starts up a rails console really quick.

The speed is the same with or without RadRails.

Michal Burak wrote in post #954952:

The speed is the same with or without RadRails.

What operating system are you using? I have heard this complaint many
times with certain Windows versions (may all versions).

If you're on some form of UNIX/Linux based system then your problem is
likely something else that can be fixed. Also if you're on one of he
*NIX based systems then I would recommend running autotest. With
autotest you only have to pay the spin-up cost once (which should only
be a couple of seconds generally) for each start of autotest. Plus,
autotest will reduce the number of test that must be executed since it
detects which file has changed and runs only the test in related files.

I've had some success with snailgun, it does pretty much what you are
asking for (speeding up preload)

http://kresimirbojcic.com/2010/11/speeding-up-rails-testing-cycle/

Best Regards,

Kreso

i have the same problem and i dont use a IDE , im on ubuntu 10.04 rails 3.0.1 and ruby 1.9.2 with rvm

check this out

time rspec spec/models/user_spec.rb

Finished in 0.80685 seconds
3 examples, 0 failures

real 0m19.700s
user 0m18.045s
sys 0m1.332s

less than a second for the test and a total of 20 for the entire process , does anyone knows what going on?