Rails 7 Bootstrap problem

Hi everyone,

I started new project with rails 7 and ruby 3 : rails new erdemsproject --css=bootstrap $rails g controller page index (after that in routes: root “home#index” )

$rails s

And I’m giving a basic error in localhost’s red page:
The asset “application.js” is not present in the asset pipeline. on the:

<%= javascript_include_tag “application”, “data-turbo-track”: “reload”, defer: true %>

What is the mistake? I instralled yarn, npm, npx and ruby again and again. But didnt solve. Note: My OS is Windows 10

I couldn’t solve the problem. I tried ./bin/dev and also i used ubuntu. I tried so much things.

I think rails 7 is not stable yet. It needs time to fix. My main reason is to choose rails 7 for turbo and stimilus. rails 6 is more complicated but solutions are solid and useful. I wonder that can i use turbo and stimilus in rails 6?

I just want to explain why it is hard to find someone answering.

It is basically because everyone choose different config now. For me, I use Propshaft + Webpack (and yes, also bootstrap, via Webpack). I have no complaint whatsoever for Rails 7 asset pipelining. It is just delegate everything to Webpack.

Rails 7 is rock solid for me in that regards. It might be hard to find someone with the same option as yours.

P.S. I don’t use turbo stimulus either

Did you run bin/rails db:create (I knew that this was needed, but tried rails s and got an error which I fixed) and then no errors with routes.rb unchanged.

But routes.rb needs to be root "page#index".

ruby “3.1.0”

gem “rails”, “~> 7.0.2”, “>= 7.0.2.4”

macOS

image