Rails 3 Phusion Passenger - Ruby (Rack) application could not be started

I am getting this message "Ruby (Rack) application could not be
started" when I attempt to run my application on Apache with Phusion
Passenger. Under Webrick it runs just fine.

This is what appears on the screen:

# File

       Line Location
0 /home/pjt/.rvm/rubies/ree-1.8.7-2010.01/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb
  31 in `gem_original_require'
1 /home/pjt/.rvm/rubies/ree-1.8.7-2010.01/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb
  31 in `require'
2 /home/pjt/quote/config/boot.rb 4
3 /home/pjt/.rvm/rubies/ree-1.8.7-2010.01/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb
  31 in `gem_original_require'
4 /home/pjt/.rvm/rubies/ree-1.8.7-2010.01/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb
  31 in `require'
5 /home/pjt/quote/config/application.rb 1
6 /home/pjt/.rvm/rubies/ree-1.8.7-2010.01/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb
  31 in `gem_original_require'
7 /home/pjt/.rvm/rubies/ree-1.8.7-2010.01/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb
  31 in `require'
8 /home/pjt/quote/config/environment.rb 2
9 /home/pjt/.rvm/rubies/ree-1.8.7-2010.01/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb
  31 in `gem_original_require'
10 /home/pjt/.rvm/rubies/ree-1.8.7-2010.01/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb
  31 in `require'
11 config.ru 3
12 /home/pjt/.rvm/rubies/ree-1.8.7-2010.01/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/builder.rb
  46 in `instance_eval'
13 /home/pjt/.rvm/rubies/ree-1.8.7-2010.01/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/builder.rb
  46 in `initialize'
14 config.ru 1 in `new'
15 config.ru 1

Any idea what the problem is? I am using Rails 3 Beta3.

Regards,

Paul Thompson

There’s normally an actual error above that, you’ve posted the stack trace (which is useful after you know what the error is).

Cheers,

Andy

Hi,

I was getting the same error as you, I did try install rails 3 beta 3 with some ruby versions, also tryed to install with the new passenger 2.2.12 available on Github, but always getting an error like that. Or just ruby crash when trying to load a simple scaffold or trying to see information throu “About your application’s environment”.

Passenger says that could’t load the rack gem and ask me to install it, but it has already installed. Even adding the GEM_PATH to the .bashrc file.

I google it a lot, spent lot of time with no result.

I think that maybe the best thing to do is wait for the final version.

Kleber Shimabuku

Just curious if you tried removing the "config.ru" file from your
rails application's root directory? It seems to be a different error
than me but I thought I would throw it out there just in case it
helps.

My environment is:

  FreeBSD 6.4
  Ruby 1.9.1p378
  Passenger 2.2.11
  Rails 3.0.0.beta3

I did, it then complained that it could not find "config.ru"

Regards,

Paul Thompson.

Ack. Sounds like a different problem then. Passenger would not start
at all for me with the config.ru file intact.

Dan