I am attempting to install Rails 3.1 with Ruby 1.87 (because Ruby 1.93
broke all of my Rails 2 projects). But, the Rails 3.1 gem is
complaining that it needs Ruby 1.9.2 to install linecache19. So, does
this mean that Rails 3.1 needs Ruby 1.92, or can Rails 3.1 be
installed with Ruby 1.8.7?
According to http://guides.rubyonrails.org/3_1_release_notes.html, Rails3.1
requires Ruby 1.8.7 or higher. I’ve tried creating a 3.1 app using rvm 1.8.7 p302
and it works fine. No dependency to linecache19. I think I’ve only needed
linecache19 if I add ruby-debug19 (this is 1.9.x specific) in my Gemfile. If
you have that, change it to ruby-debug and rerun bundle install.