Rails 3.0.5 has been released!

# Rails 3.0.5 has been released!

## Bugs Fixed:

  * Fix when gzip returns a UTF-8 string on Ruby 1.9, when it is actually
    binary.

    31690ea8b3420aea4ea4427e1599665d093c974f
  
  * ActiveRecord limit values will not escape Arel SQL Literal nodes

    7530c5224c77202d62f44a26ae5036d1dc00f579

  * Relation#where() calls will always produce AND statements regardless of how
    conditions hashes behaves (reverting 00693209ecc).

    41c35abed778a7a03e7a9c14009321cd6bc11c26

  * Observer callbacks will only be executed once when using STI classes in
    ActiveRecord.

    ee491b064bff126a67600d694511986b8636d47b

## Deprecations Added:

  * Deprecate Relation#& alias for Relation#merge

    66003f596452aba927312c4218dfc8d408166d54

  * Deprecated support for interpolated association conditions with the
    :conditions => 'foo = #{bar}' syntax, and added the new interpolation syntax
    which is :conditions => proc { "foo = #{bar}" }.

    756e70cb4492ded56b72b1601da7d198eaf7b840

This is not a complete list of changes. The complete list of changes can be
found here:

  https://github.com/rails/rails/compare/v3.0.4...v3.0.5

## Checksums:

    SHA1(actionmailer-3.0.5.gem) = b25750c8126aa21db27d7b0ee829b2e94e525ebc
    SHA1(actionpack-3.0.5.gem) = 0a6f7f9ac2960ff224c913877a2917e1bea80df3
    SHA1(activemodel-3.0.5.gem) = 1556900a7afa1cdcdf4641edbcdd2c24f98bb2de
    SHA1(activerecord-3.0.5.gem) = 33dd05d7362931564f6f15ea7130cc27a5fc09e8
    SHA1(activeresource-3.0.5.gem) = 758f893cbb7ef945c857bf4ca044b94017bdc437
    SHA1(activesupport-3.0.5.gem) = 195fa3f7fa044134703a655cdb906edb515286c4
    SHA1(rails-3.0.5.gem) = 32322bf9952d76c5fa0054c8533c0c58609f40aa
    SHA1(railties-3.0.5.gem) = 3dddf14736dec991c3dbbe2d89495613e72c19c7

This is my first actual rails release! I hope you all enjoy!

<3 <3 <3 <3

maybe a trivial err, but i get,

.....
Installing ri documentation for rails-3.0.5...
file 'lib' not found

reinstalling rails get the same result.

this my first hitch on a rails update though, and the err message is
not so clear either =)

thanks for rails updates and best regards -botp

hm, possibly ri/rdoc-related since i get no err if i do

   $ sudo gem install rails --no-ri --no-rdoc

thanks -botp

No problems installing on OSX, ri and rdoc installed fine into rvm.
Will try Ubuntu, CentOS and Win later, none of which use rvm.

Is anyone seeing odd errors with 3.0.5? I am seeing odd behavior
between 3.0.3 and 3.0.5. Namely, this statement...

site.featured_medias.where(:media_type => media_class, :unfeatured_at
=> nil).order("created_at desc").first

... works in 3.0.3, but produces this bad SQL in 3.0.5....

Mysql::Error: Table 'remix3_development.featured_media' doesn't exist:
SELECT `featured_media`.* FROM `featured_media` WHERE
`featured_media`.`media_type` = 'Message' AND
`featured_media`.`unfeatured_at` IS NULL AND (`featured_media`.site_id
= 1) ORDER BY created_at desc LIMIT 1

Note the table name is not pluralized. In my case, Site
has_many :featured_medias

FeaturedMedia does include a class method named featured_media, ala...

class FeaturedMedia < ActiveRecord::Base
...
  def self.featured_media(site, media_class)
  ...
  end
end

and the .where above is called within FeaturedMedia.featured_media.

That code also works in 3.0.4, but does not in 3.0.5.

Same here. I just upgraded from 3.0.3 to 3.0.5 and there is one model out of ~20 that fails to construct the table name properly:
$ rails console
Loading development environment (Rails 3.0.5)
ruby-1.9.2-head :001 > pm = PackageMeta.new
Mysql2::Error: Table ‘uupdates_dev.package_meta’ doesn’t exist

The table name should be package_metas. It was working fine in 3.0.3.

I guess it is assuming media and meta are both already plural, which
media is of course so strictly the model should be medium. Not sure
about meta though, one metum two meta?

Colin

Excellent catch. I extended my local list of unusual inflections in
config/initializers.

ActiveSupport::Inflector.inflections do |inflect|
  inflect.irregular 'media', 'medias'
  inflect.irregular 'missive', 'missives'
  inflect.irregular 'criterion', 'criteria'
end

I'm new to rails and i want to use mysql with rails 3.0.5 on windows 7.
When I run the command
rake db:create
I get a pop up box saying that SQLite3.dll is missing.

What should I do?

Use google?

http://www.ruby-forum.com/topic/149431

The same error here…On Ubuntu 10.10

And when I run “rails server” it says "=> Rails 3.0.4 application starting in development on http://0.0.0.0:3000 " instead of 3.0.5, is it normal?

Thanks, byyye!

Stop using windows :slight_smile: