Rails 2.3.3 script/server problem

Hi Guys

I installed ruby 2.3.3 a few days ago & I'm struggling to start the
servers. I'm using windows XP professional.

If I run run script/server, I get the following error:

=> Booting WEBrick
=> Rails 2.3.3 application starting on http://0.0.0.0:3000
g:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.3/lib/initializer.rb:602:in
`send': und
efined method `cache_template_extensions=' for ActionView::Base:Class
(NoMethodE
rror)
        from g:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.3/lib/
initializer.rb:602:i
n `initialize_framework_settings'
        from g:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.3/lib/
initializer.rb:601:i
n `each'
        from g:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.3/lib/
initializer.rb:601:i
n `initialize_framework_settings'
        from g:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.3/lib/
initializer.rb:598:i
n `each'
        from g:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.3/lib/
initializer.rb:598:i
n `initialize_framework_settings'
        from g:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.3/lib/
initializer.rb:155:i
n `process'
        from g:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.3/lib/
initializer.rb:113:i
n `send'
        from g:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.3/lib/
initializer.rb:113:i
n `run'
         ... 6 levels...
        from g:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.3/lib/commands/
server.rb:8
4
        from g:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `ge
m_original_require'
        from g:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `re
quire'
        from script/server:3

Please help me guys.

Thanks in advance.

WalT

Walt,

Could you try commenting
"config.action_view.cache_template_extensions" in your development.rb
and then start the server.

Thanks,
Kilari.

Hi Kilari

Many thanks to you! Your solution worked!

Now I can stat the servers and do a local test by typing http://localhost:3000.

Now I'll try the scaffolding command to see if now I can proceed
learning ruby on rails.

Tx

WalT