quote_ident

We have updated the rails version from 2.1.1 to 2.3.3 and we get the
folowing error message:

undefined method `quote_ident' for PGconn:Class

Any idea about it?

Thanks in advance.

I have the very same problem when migrating from rails 2.3.2 to 2.3.3.
Nothing else has been modified.

Please help...

Shall we wait for a new version of postgres-pr (actual 0.6.1) ?

Thanks

OK. Now there is a temporary solution, I suppose before postgres-pr
gets updated... It's very well explained here :
http://github.com/mneumann/postgres-pr/issues/unreads#issue/1

You need to add to : config/initializers/new_rails_defaults.rb, the
following :

def PGconn.quote_ident(name)
    %("#{name}")
end

That fix is being ignored in my case. Win XP

I get exactly the same error.

When I run the console it is modifying the class however.

ha... my problem was I was running a rake take
so the initializers weren't being run

this seems to have worked for me:
rake db:create:all -P development

Yes I hit that problem as well. It can be addressed by placing the
patch directly into active_record rather than into
new_rails_defaults.rb as suggested earlier. i.e. whack the patch in:

   active_record/connection_adapters/postgresql_adapter.rb

cheers,
mick