Proposed aliasing `saved_change_to_name?` to `save_has_changed_name?`

Hello everyone :wave:,

I understand that saved_change_to method shouldn’t go away. That is a pretty major change. Just thinking that save_has_changed_name? sounds a bit better? With this, I think we can also use save_changed_name_to

I would like to share that everytime I have to use Dirty, I always check the documentation again and again. I was never able to intuitevly type the correct name of save_*?

Not sure what would be the Intuitive way though