Problems installing Rmagick on Ubuntu

I want to install Rmagick on Ubuntu 7.10, but i am getting this error
when running gem install rmagick:

Can't install RMagick 2.2.0. You must have ImageMagick 6.3.0 or later.

(I installed imagemagick and libmagick9-dev prior to that)

I installed rmagick through Synaptic, and it says that i have version
7:6.2.4.5.dfsg1-2ubuntu1 installed (by the way, what does the 7
mean?). What should i do to have the gem install correctly?

Is it possible you need to run ldconfig? Or add something to your
/etc/ld.so.conf ?

I know for 6.06 there is a libmagick-ruby library that needs to be
installed as well.
- Richard

I have no idea, should i? And if so: how? :slight_smile:
I'm a newbie to Ubuntu...

And I have libmagick-ruby and libmagick-ruby1.8 installed.

Could someone 'sew up' this topic and possibly list what one must do
to install RMagick upon a Ubuntu 7.10 configuration?
I would be most grateful as I too, am like many who have failed at
this endeavor.
Thank you,
Kathleen

This should do the trick.

sudo apt-get install ruby rubygems irb ri rdoc ruby1.8-dev build-
essential imagemagick libmagick9 libmagick9-dev

sudo gem install rmagick -v=1.15.10

richard@richard-desktop:~$ irb
irb(main):001:0> require 'rubygems'
=> true
irb(main):002:0> require 'RMagick'
=> true
irb(main):003:0> Magick::CenterGravity
=> CenterGravity=5
irb(main):004:0>

Hi Thanks,

It is very helpful for me.

Shrikant