Problem with rails generaterspec:install, Error-Message: no such file to load, sprockets-railtie (loadError)

Hey guys,

I'm a RoR-Beginner and I started learning it with the RoR-Tutorial.
Actually I'm at this chapter (http://ruby.railstutorial.org/chapters/
static-pages#top) and try to install rspec. But everytime when I try
to use "rails g rspec:install" I get this error message:

C:\Sites\rails\rails_projects\sample_appp>rails g rspec:install
C:/Sites/rails/rails_projects/sample_appp/config/application.rb:8:in
`require':
no such file to load -- sprockets/railtie (LoadError)
        from C:/Sites/rails/rails_projects/sample_appp/config/
application.rb:8:i
n `<top (required)>'
        from C:/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/
railties-3.0.9
/lib/rails/commands.rb:15:in `require'
        from C:/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/
railties-3.0.9
/lib/rails/commands.rb:15:in `<top (required)>'
        from script/rails:6:in `require'
        from script/rails:6:in `<main>'

Has anybody an idea to help me? I already tried to comment it out in
the application.rb or to explicitly mention it in the gemfile. But I
still get this error message.

Would be great if anyone could help me. Btw. my OS is Windows XP and
I'm using Ruby version 1.9.2.p290 and Rails version 3.1.0.rc6.

Hey guys,

I'm a RoR-Beginner and I started learning it with the RoR-Tutorial.
Actually I'm at this chapter (http://ruby.railstutorial.org/chapters/
static-pages#top) and try to install rspec. But everytime when I try
to use "rails g rspec:install" I get this error message:

C:\Sites\rails\rails_projects\sample_appp>rails g rspec:install
C:/Sites/rails/rails_projects/sample_appp/config/application.rb:8:in
`require':
no such file to load -- sprockets/railtie (LoadError)

This might indicate a gem is missing.

what "gem list sprockets" display?

Did you ensure your bundle is installed (doing "bundle install" at the
project directory)

Has anybody an idea to help me? I already tried to comment it out in
the application.rb or to explicitly mention it in the gemfile. But I
still get this error message.

See above questions, is sprockets gem installed?

Hi,

Did you ever got over this issue ? I am also having same issue. Would
really appreciate if you could update me if you were able to resolve
this issue.

Thanks in advance
Jony Malhotras

Anna.Garance wrote in post #1018516: