Problem with installing rails 3.2

Hi,

When i tried to install rails 3.2, i am facing problems like

Invalid gemspec in [/home/nthillaiarasu/.rvm/gems/ruby-1.9.2-
p0@rails32/specifications/activemodel-3.2.0.gemspec]: Illformed
requirement ["#<Syck::DefaultKey:0xa5933a0> 3.2.0"]
Invalid gemspec in [/home/nthillaiarasu/.rvm/gems/ruby-1.9.2-
p0@rails32/specifications/activemodel-3.2.0.gemspec]: Illformed
requirement ["#<Syck::DefaultKey:0xa5933a0> 3.2.0"]

Ruby version i am using was ruby 1.9.2p0

I found this:

http://stackoverflow.com/questions/7379385/invalid-gemspec-in-and-illformed-requirement-whenever-i-create-a-new-project

Problem solved,i just upgraded the ruby gems

gem update --system

gem install rails