Problem when trying to freeze gem (XP user)

I am on XP. This is the first time I am trying to freeze to a gem.
This is what I get:

rake rails:freeze:gems --trace
(in C:/Documents and Settings/Sultan/My Documents/Aptana Studio/
** Invoke rails:freeze:gems (first_time)
** Execute rails:freeze:gems
Freezing to the gems for Rails 2.2.2
rm -rf vendor/rails
mkdir -p vendor/rails
cd vendor/rails
Unpacked gem: 'C:/Documents and Settings/Sultan/My Documents/Aptana
Studio/upload/vendor/rails/activesupport-2.2.2'mv activesupport-2.2.2

rm -rf vendor/rails
rake aborted!
Permission denied - activesupport-2.2.2 or activesupport
c:/ruby/lib/ruby/1.8/fileutils.rb:505:in `rename'
c:/ruby/lib/ruby/1.8/fileutils.rb:505:in `mv'
c:/ruby/lib/ruby/1.8/fileutils.rb:1395:in `fu_each_src_dest'
c:/ruby/lib/ruby/1.8/fileutils.rb:1411:in `fu_each_src_dest0'
c:/ruby/lib/ruby/1.8/fileutils.rb:1393:in `fu_each_src_dest'
c:/ruby/lib/ruby/1.8/fileutils.rb:494:in `mv'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1072:in `mv'
26:in `each'
c:/ruby/lib/ruby/1.8/fileutils.rb:121:in `chdir'
c:/ruby/lib/ruby/1.8/fileutils.rb:121:in `chdir'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1072:in `chdir'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:617:in `call'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:617:in `execute'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:612:in `each'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:612:in `execute'
c:/ruby/lib/ruby/1.8/monitor.rb:238:in `synchronize'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:564:in `invoke'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1997:in `each'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1970:in `run'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1967:in `run'
c:/ruby/bin/rake:19:in `load'

Urgent Please! Someone help!

Urgent Please help

If you manually unpack the activesupport-2.2.2 gem, can you rename the
directory it creates? Try this at the command line:

gem unpack activesupport --version '= 2.2.2'
mv activesupport-2.2.2 activesupport

Also, for reference, what version of Rubygems are you running (do a
'gem --version')?

CC me directly for quicker replies.

--Matt Jones

I guess I am running 1.3.1. I thought I was running 2.2.2

Hi Matt,

In my "my documents" directory (outside of Aptana Studio) I created a
new project "rails testout -d mysql", then in the testout directory
(cd testout) I tried "rake rails:freeze:gems" and still get the same
error. I can't figure out why this won't work.

I then created a new project in Apatana Studio "testin". I then did
(in the command line) the rails:freeze:edge RELEASE=2.2.2 step
manually and made sure that I unzipped the file in /testin/vendor
directory. It seems to work. I can start the server and run rake jobs.
The only thing missing is rails/
REVISION_dc88847e5ce392eed210b97525c14fca55852867. Do you think this
is a good work around?

There's still something really weird going on with your Rubygems
install, but I haven't got any ideas on how to debug it. Maybe some
other Windows users here can help? It wouldn't hurt, of course, to do
the standard Windows troubleshooting routine (remove your Ruby install
and try again)...

Freezing to edge works, but I'd encourage you to upgrade to 2.3.2 if
at all possible. While the shiny new features may get all the press,
there are *many* bug fixes in there as well.

--Matt Jones