Problem running Flex&Ruby on Fedora 7

public class Users
  {
    private var service:HTTPService;

    [Bindable]
    public var xmllist_user:XMLList;
    [Bindable]
    public var xmllist_user_right:XMLList;

    [Bindable]
    public var enabled_remove_user_right:Boolean = false;

    //--------------------------------------------------
    // Used : Constructor of Users
    // V : 1.1 Des : Set property value to the 'service' variable
    public function Users(){
      service = new HTTPService();
      service.method = "POST";
      service.useProxy = false
      service.resultFormat = "e4x";
    }

    //--------------------------------------------------
    // Used : get all the user name to store in 'xmllist_list'
    // V : 1.1 Des : First create function for list user
    public function listUser():void{
      service.url = "/user/get_all_user_group_name";
      service.addEventListener("result", httpResultListUser);
      service.addEventListener("fault", httpFaultListUser);
      service.send();
    }
    private function httpResultListUser(event:ResultEvent):void{
      service.removeEventListener("result", httpResultListUser);
      service.removeEventListener("fault", httpFaultListUser);
      xmllist_user = new XMLList(service.lastResult.children());
    }
    private function httpFaultListUser(event:FaultEvent):void{
      var faulstring:String = event.fault.faultString;
      service.removeEventListener("result", httpResultListUser);
      service.removeEventListener("fault", httpFaultListUser);
      Alert.show(faulstring,"Error");
    }

}

Hi all,
the above is my coding from Flex 2 and Ruby. Actually, it works well
on windows there is nothing bug when I run it on Windows platform but
when I run it on Linux Fedora 7 it produce the bug at "service.url = "/
user/get_all_user_group_name". It seem it doesn't know when I call my
controller "user" then my method "get_all_user_group_name". When I run
it, it produces the error message as below:
Error
[RPC Fault faultString="HTTP request error"
faultCode="Server.Error.Request"
faultDetail="Error: [IOErrorEvent type="ioError" bubbles=false
cancelable=false eventPhase=2 text="Error #2032: Stream Error. URL: /
user/get_all_user_group_name"]. URL: /user/get_all_user_group_name].

Well, I compile my application on windows platform and I run it on
Fedora 7. Does it can be cause of the wrong compiler? IF so how can
you recommend how can I compile my flex application on Linux Fedora 7?
Regards,
Sok