Problem In Rails Server Command

Hello Everyone
I have install rails in my laptop. I am using Ubuntu Operating System.
I create an app using $ rails new abc
and then go to the abc folder and type rails server then i got error:

Add to Gemfile
gem 'execjs'
gem 'therubyracer'
and then bundle install.

Colin

Is there permanent solution for that. You are saying that i have to
add each time these gem in my each new rails app.

Is there permanent solution for that. You are saying that i have to
add each time these gem in my each new rails app.

That is a permanent solution. Hardly a big deal compared to the
amount of work required to develop the app itself. If you google a
bit you will find the background. I believe they are not put there by
default as there are other options, if you were using jRuby for
example I believe it would be different.

Colin

You will have to do something yes.

In the newer versions of Rails (4.0.0.beta) the
# rubyracer
line is already there, but commented out.

What I do, is to take this order:

$ rails new name_of_app --skip-bundle
$ vim Gemfile # add "gem 'therubyracer'"
$ bundle install

so I don't have to wait 2 times for bundle install.

Actually, to not have to type --skip-bundle every time, I have this
.railsrc defaults file:

~$ cat ~/.railsrc
--skip-bundle
-T
-d postgresql

HTH,

Peter

Thank You Colin