Problem in installing community_engine plugin

Hi,

I am new to ROR and trying to deploy the community_engine module to a clean ROR project.

When I follow all the instructions here:

And run " ./generate plugin_migration"

I get this error:

vendor/plugins/community_engine/config/initializers/sessions_middleware.rb:1: undefined method `middleware' for ActionController::Dispatcher:Class (NoMethodError)   from /vendor/rails/activesupport/lib/active_support/dependencies.rb:142:in `load_without_new_constant_marking'   from /vendor/rails/activesupport/lib/active_support/dependencies.rb:142:in `load_without_desert'   from /vendor/rails/activesupport/lib/active_support/dependencies.rb:521:in `new_constants_in'   from /vendor/rails/activesupport/lib/active_support/dependencies.rb:142:in `load_without_desert'   from /var/lib/gems/1.8/gems/desert-0.5.3/lib/desert/ruby/object.rb:18:in `load'   from /var/lib/gems/1.8/gems/desert-0.5.3/lib/desert/ruby/object.rb:32:in `__each_matching_file'   from /var/lib/gems/1.8/gems/desert-0.5.3/lib/desert/ruby/object.rb:17:in `load'   from /vendor/plugins/community_engine/config/boot.rb:5   from /home/utkarsh/Desktop/SJSU MS-SE/My Dropbox/Dropbox/my-personal-documents/tech/ROR/knowledgebin/vendor/plugins/community_engine/config/boot.rb:4:in `each'   from /vendor/plugins/community_engine/config/boot.rb:4   from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'   from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'   from /vendor/rails/activesupport/lib/active_support/dependencies.rb:153:in `require_without_desert'   from /vendor/rails/activesupport/lib/active_support/dependencies.rb:521:in `new_constants_in'   from /vendor/rails/activesupport/lib/active_support/dependencies.rb:153:in `require_without_desert'   from /var/lib/gems/1.8/gems/desert-0.5.3/lib/desert/ruby/object.rb:8:in `require'   from /var/lib/gems/1.8/gems/desert-0.5.3/lib/desert/ruby/object.rb:32:in `__each_matching_file'   from /var/lib/gems/1.8/gems/desert-0.5.3/lib/desert/ruby/object.rb:7:in `require'   from /config/environment.rb:22   from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'   from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'   from /vendor/rails/railties/lib/commands/generate.rb:1   from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'   from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'   from ./generate:3

My installed gems are:

*** LOCAL GEMS ***

actionmailer (2.3.5, 2.3.4, 2.3.3) actionpack (2.3.5, 2.3.4, 2.3.3) activerecord (2.3.5, 2.3.4, 2.3.3) activeresource (2.3.5, 2.3.4, 2.3.3) activesupport (2.3.5, 2.3.4, 2.3.3) appengine-apis (0.0.15) appengine-jruby-jars (0.0.7) appengine-rack (0.0.8) appengine-sdk (1.3.3.1) appengine-tools (0.0.12) authlogic (2.1.3) aws-s3 (0.6.2) builder (2.1.2) bundler08 (0.8.5) calendar_date_select (1.16.1) desert (0.5.3, 0.5.2) google-appengine (0.0.12) haml (2.0.5) hpricot (0.8.2) htmlentities (4.2.1) icalendar (1.1.4) jruby-rack (0.9.7) mime-types (1.16) progressbar (0.9.0) rack (1.1.0, 1.0.1) rails (2.3.4) rake (0.8.7, 0.8.3) ri_cal (0.8.7) rmagick (2.13.1) rubyzip (0.9.4) searchlogic (2.4.19) xml-simple (1.0.12)

and ruby -v: ruby 1.8.7 (2010-01-10 patchlevel 249) [i486-linux]

Any ideas?

Similar problem is posted here: http://groups.google.com/group/communityengine/browse_thread/thread/4f566f99284ee1db/f17bce1804973f14

But by upgrading Rails to 2.3.3 worked for him, I have downgraded from 2.3.5 to 2.3.4 and also tried on 2.3.3. But I get the same error.