Problem getting Nginx & Unicorn to work for Railo 4 on Ubuntu 12.04

Hi, I’m having a bit of aggro getting Unicorn and Nginx setup to where Uncorn.rb actually loads. Second prob is getting Nginx to properly recognize the new app listed as server in nginx.conf

Does anyone know of any good articles on this setup? I’ve looked a tried a few but with no success. Puma & Apache setup worked just fine, but I’m really keep to go Nginx/Unicorn.

My stack is Ubuntu 12.04 / Nginx / Railo 4 / Unicorn.


I have a project I’ve been working on to automate the setup of a rails server on Amazon EC2. There are bash scripts to set up Nginx with/without SSL and sample config files for unicorn. Everything is tested with Rails 4.

Take a look at the /projects, /unicorn, and /nginx folders for related stuff.

I am working on improving the documentation, but there are comments in the setup_*.sh scripts that explain a lot. I’ve not tested it on Ubuntu (only Amazon Linux instances, which are redhat based) but you should be able at least get some good info there.